WLAN-Ärger 2.0

Vor einer Weile fing mein W-LAN wieder an zu zicken. Damit hatte ich ja schon bei der Einrichtung zu kämpfen gehabt. Wieder wurden Videos nicht flüssig angezeigt, und manchmal brach die Verbindung ganz ab.

Zuerst hatte ich probiert, den Kanal zu wechseln. Aber wie in der Stadt üblich ist da natürlich keiner, auf dem man allein ist. Auf den oberen Kanälen, auf denen ich bisher gefunkt hatte, saß ich schon ganz gut. Eine Veränderung hat dann auch keine Besserung gebracht.

Also habe ich mich auf die Suche nach neuer Hardware gemacht…

Eine gute Lösung gegen überlaufene Kanäle sollten derzeit 5-GHz-Router sein. Diese Frequenzen werden noch nicht so häufig verwendet, außerdem gibt es dort viel mehr überlappungsfreie Kanäle. Allerdings dürfen die meisten davon hierzulande nur verwendet werden, wenn der Router nach anderen Signalen wie Radar horcht und gegebenenfalls den Kanal wechselt. Das können bezahlbare Router wohl meist nicht, und über 100 Euro wollte ich nicht ausgeben. Und auf ein neues Frequenzband auszuweichen, nur um dort gleich wieder in der Enge zu sitzen, ging mir auch gegen den Strich. Den alten Router einfach gegen einen gleichwertigen ersetzen, dafür einiges an Geld ausgeben und am Ende vielleicht wieder Übertragungsprobleme zu haben hörte sich aber auch nicht verlockend an.

Schließlich habe ich einen Router für unter 20 Euro gefunden, der mit 150 MBit funkt. Ein DSL-Modem ist nicht integriert, aber das funktioniert ja bei meinem alten Router, der kann also für den neuen das Modem geben. Zusätzlich ließe sich der Router, TL-WR740N von TP-Link, mit OpenWRT bespielen, einer freien Firmware für Router. Wenn er nicht von Hause aus helfen würde, könnte ich so vielleicht noch mehr rausholen. Und wer den beiden Antennen des Routers nicht traut, kann für wenig mehr Geld den TL-WR740ND kaufen und sie auswechseln.

Den Ausschlag hat allerdings gegeben, dass bei einem ehemals auf Bücher spezialisierten Internet-Versandhaus 140 von 150 Rezensionen positiv waren (4 bis 5 Sterne). Drei Prozent schlechte Bewertungen (1 bis 2 Sterne) hat wohl selbst das beste Produkt, zumal solche mit Kommentaren wie „Ich habe es probiert mit verschiedene Internet Herstellers aber es hat da angleiche Problem von Firma können es auch nicht reparieren.“ …

Die Einrichtung unter Linux hat mir ein paar Schwierigkeiten bereitet. So richtig kenne ich mich immer noch nicht mit der händischen Konfiguration aus, und die vorhandenen grafischen Tools scheinen meine eigentlich übersichtliche Netz-Topologie nicht zu unterstützen. Aber nach einem gefühlten Stündchen lief das Netz. Wie am Schnürchen. Es ist ein schöner Anblick, wenn man beim Videoportal seines Vertrauens den Ladebalken kontinuierlich und weit vor dem Anschau-Balken anwachsen sieht!

Zum Router hatte ich mir noch einen W-LAN-Adapter für den Rechner gekauft. Den dann aber gleich, hoffentlich zukunftsweisend, 5-GHz-fähig. Zwar nicht auf allen möglichen Kanälen, aber mehr als auf den vieren, auf die die einfachen Router beschränkt sind. Den Adapter – der fast soviel gekostet hat wie der Router – habe ich aber noch gar nicht in Betrieb genommen. Es klappt auch ohne gut, und für den neuen Chip im Adapter müsste man sich den Treiber derzeit noch selbst installieren, er ist gerade erst in eine zukünftige Kernel-Version eingeflossen.

So jedenfalls der Stand am Freitag. Bis das Netz-Gezicke wieder losging.

Das Netz fühlte sich wieder „unrund“ an. Ich konnte das schließlich an zu hohen und wackeligen Ping-Zeiten festmachen. Mal bei 30/40 Millisekunden, mal über 100 …

Also habe ich Sonntag Nachmittag mit Treiber Kompilieren statt mit Frozen Synapse verbracht. Der WLAN-Stick heißt TL-WDN3200, der Chip darin RT5572. Ich habe diese Anleitung verwendet. Am längsten habe ich dann daran gehangen, dass mir nicht aufgefallen ist, dass sich das Gerät als „ra0“ statt als „wlan0“ bezeichnet hat und damit meine Regeln in der Konfigurationsdatei /etc/network/interfaces nicht zum Tragen kamen. Danach hatte ich berauschende Ping-Zeiten zum Router. Einstellige Millisekunden oder sogar welche unter 1. Das sieht gut aus.

Nach gefühlten zwei Stündchen lief das Netz. Wie am Schnürchen. Es ist ein schöner Anblick, wenn man beim Videoportal seines Vertrauens den Ladebalken kontinuierlich und weit vor dem Anschau-Balken anwachsen sieht!

Ja, das hab ich schon mal geschrieben, schon mal gedacht…

Aber diesmal ging ein Dutzend Seiten, gleichzeitig geöffnet, schneller auf, als ich die Tabs durchklicken konnte. Und irgendwann muss es dochmal dauerhaft stabil und schnell laufen…?

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.